How to Create a Service via Import

Users can add a Service to SCRIBE manually and through an import. This PDF covers adding a service via
import. See How to Create A Service manually article on the SCRIBE Help Desk.

Create the File to Import
1. Determine the required and optional fields for a Service import. There are two ways:
a. Look at the Import Template in your grant’s Google Drive folder. Every import template has a
tab that has the field headings and a tab that describes each field, whether the field is required,
the type of data needed for that field and where to find that data.
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1 |ProgramID|SewiceName |5ch00INumber|SchoolYea |Star‘t[]ate|EndDate|ServiceTyp |ServiceTypeld |ServiceDeIiveryCategoryld Sen
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SampleFileFormat FieldsDescribed Service Type Category ID Service Type ID ()]
A B C D E F
1 |Column |Field Name Field Length | Required? |Comments Values
A ExternalServicelD 50 Required |This is a unigue value that is the same as the
service name using the GEAR UP Service Naming
2 Conventions.
B ServiceName 50 Required |Service Name using GEAR UP Service Naming
3 Conventions
C SchoolNumber 10 Required |Th Unigue Identifier for the school In SCRIBE click on Schools=View
4 all Schools for School Numbers.
D SchoolYear a Required |Year of first marking period e.g., "2019" for 2013-2020 school
year, "2020" for 2020-2021 school
5 year
6 E StartDate 10 Required |Start date for which the service is/was active MM/DD/YYYY
7 F EndDate 10 Required |Date for which the service began to be active MM/DD/YYYY
8 G ServiceTypeCategoryld Required |Category for the service type of the service Service Type Category IDs
H ServiceTypeld Required | Service type that the service fulfilled In SCRIBE click on Reports =
SCRIBE Configuration > Service
Taxonomy
9
1 ServiceDeliveryCategoryld Required | Category for the service delivery of the service [8: Virtual
9: Real (In-Person)
10 10: Telephonic
J ServiceDeliveryld Required | How the service was delivered 25: Virtual
26: Real (In-Person)
11 27: Telephonic
K ServiceTimingCategoryld Required 8
12
L ServiceTimingld Required 27
13

Note: Remember to download the Import Template from the Google folder and save it on your desktop
before editing it. Click File > Download > Microsoft excel.


https://xcalibur.freshdesk.com/a/solutions/articles/4000151987
https://xcalibur.freshdesk.com/support/home
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a. The second way to determine the required fields: In SCRIBE click Tools > Import. Click Add
Import. Select the Import Type. Click the View Specification button.

SCRIBE/  ScRisE support

GEAR UP Demo_Current # SCRIBE Import € Back to SCRIBE
=
Add Import

Import Source a Provide your data as a CSV (comma-separated variable) file or MS Excel

(XLSX) file with one Worksheet. It's best to only include the data you
intend to be imported into SCRIBE.

TSI TR |
@ View Specification

GEAR UP Demo - Cohort Model

Import Type [11]
School Year
Service List
2019- 2020 v
Import Config Data File
GEAR UP Demo - Cohort Model - Service List Choose impart data file Browse

AO—
£ Upload Import File

The Import Specification list will appear in a popup box. The fields with a red asterisk are required, the
other fields are optional.

Import Specification X

GEAR UP Demo - Cohort Model - Service List
This import is used to add Services and assign them to Schools. This file should be uploaded and
successfully imported before the Service Participation file.

% = Required - field must be in your file
O = Opticnal - field should only be in your file if you are providing values

Field Status Description

ExternalServiceld *  Service identifier

ServiceName %  Service name

SchoolNumber %  School identifier

SchoolYear %  School Year (ex: 2010 for the 2010-2011 school year)
StartDate O  Start Date for which the Service is/fwas active (ex: mm/dd/yyyy)
EndDate O End Date for which the Service isfwas active (ex: mm/dd/yyyy)
ServiceTypeCategoryld %  Category for the Service Type

ServiceTypeld %  Service Type - what function the Service fulfilled
ServiceTypeAdditionalinfo O  Additional info if the Service Type requires it
ServiceDeliveryCategoryld %  Category for the Service Delivery

ServiceDeliveryld %  Service Delivery - how the Service was delivered
ServiceDeliveryAdditicnallnfo O  Additional info if the Service Delivery requires it
ServiceTimingCategoryld %  Category for the Service Timing

ServiceTimingld %  Service Timing - when the Service was delivered

c PR TSN TRV SIS =)

Note: SCRIBE will consider any fields included in the import that are not listed on the Import
Specification list as “unknown” fields during the import process.
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Fields

Fields are the different data categories you can include in the Service List import file (e.g., ServiceName,
SchoolNumber, etc.) listed as separate columns in the spreadsheet. Some fields are required, meaning SCRIBE
will not import your file without them. Some are optional, meaning it is up to you whether or not to include
them in the import file.

TIP: Fields (columns) can be in the import file in any order. Field headings must be spelled correctly but
capitalization does not matter (e.g., ServiceName = servicename = SERVICENAME = sErViCenAmE). There
are no spaces in the field headings (e.g., SchoolYear is not the same as School Year).

Fields in a Service List Import (* indicates a required field)
a. ExternalServicelD*: unique value using the SCRIBE Service Naming Conventions. The
ExternalServicelD should be the same as the ServiceName.

b. ServiceName*: unique name of the service using SCRIBE Service Naming Conventions. The
ServiceName should be the same as the ExternalServicelD.

c. SchoolNumber*: In SCRIBE click Schools > View All Schools.

ScRiBe/ | SesEswet
_

Home ~ Districts = Schools = Student Search Services

View All Schools

The list of School Numbers are displayed in the School list. Copy the School Number of the school
the students attend and paste it in the Service List Import spreadsheet in the SchoolNumber field.

SCRIBE Home > School List

The following are all the available schoaols.
Click the View link to see additional details for a school. Click the Search link to filter the list of schools.

© search

Drag a column header here to group by that column

School Number 4 | School Name District Name Grades
View 1 Bayside Middle School Test District 7-8
View 2 West Beverly High School Test District 9-12
View 3 William McKinley High School Test District 9-12
View 4 DeGrassi Junior High Test District 7-8
View 5 College Test District Post-Secondary -
5 Items Pages: 1 - 1 (5 items) Page size: [All |«
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SchoolYear*: first year in the two year school year (e.g., “2019” for the 2019-2020 school year,
“2020” for the 2020-2021 school year)

StartDate: day service is/will become active.

EndDate: day service is/will become inactive.
Note: For one time services, the StartDate and EndDate will be the same date. For recurring
services, the StartDate should be the first day of the month and the EndDate should be the last
day of the month.

ServiceTypeCategorylD*: code for the service type category. See the ServiceTypeCategoryID tab in

the service list import template or the Service Taxonomy exported from SCRIBE (instructions
below).

. ServiceTypelD*: code for the service type. See the Service Taxonomy exported from SCRIBE

(instructions below).

ServiceDeliveryCategorylD*: code for the service delivery category.
Codes: 8 for Virtual

9 for Real (In-person)

10 for Telephonic

ServiceDeliverylD*: code for how the service was delivered.
Codes: 25 for Virtual

26 for Real (In-person)

27 for Telephonic

ServiceTimingCategoryID*: enter 8 in this field for all rows.

ServiceTimingID*: enter 27 in this field for all rows.

m. PersonTypel: indicated whether the service will be for students, parents or staff members.

n.

0.

Codes: 1 for student
2 for parent/guardian/family
3 for teacher/staff

Note: SCRIBE will allow a service to be assigned to up to three PersonTypes (fields are PersonTypel,
Persontype2, PersonType3). However, best practice recommends one PersonType per service. If a
service caters to more than on person type (e.g., financial aid night for parents and students),
create one service for students and another service for parents.

ISSTEM: indicates whether the service is a STEM service. Enter Yes or No.

ISELL: indicates whether the service is an ELL service. Enter Yes or No.

4



How to Create a Service via Import

p. ServiceProviderl:
Note: Up to three ServiceProviders may be added to the service list import (fields are
ServiceProviderl, ServiceProvider2, ServiceProvider3).

g. ServiceNotes: use this field to indicate any relevant information that is not part of the service name
or service summary (e.g., the destination of a field trip or if a service gets canceled).

r. ServiceTypeAdditionallnfo: Required for college visits. Enter the IPEDS number for the college
visited. IPEDS can be found at nces.ed.gov/globallocator.

Note: To retrieve the ServiceTypeCategorylID, ServiceTypelD, ServiceTimingCategoryID,
ServiceTiminglD, ServiceDeliveryTypelD and ServiceDeliveryID, export the Service Taxonomy.

In SCRIBE click Reports > SCRIBE Configuration > Service Taxonomy.

Select the Person Type(s) to narrow the services listed on the Service Taxonomy (optional). Select
Report Format to run the report as an Excel file or a PDF. Click Generate Report.

SCRIBE Home > Service Taxonomy

Service Taxonomy

Report Filters

Program Type(s): .
9 ype(s) GEAR UP General {Use for Programs not tracked in SCRIBE)

Person Type(s):

Student Parent/Guardian Staff
Select All

Report Format: * ® EXCEL PDF

Generate Report



https://nces.ed.gov/globallocator/
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ServiceTypeCategoryID

ServiceTypelD

ServiceTimingCategorylD

ServiceTiminglID

ServiceDerliveryCategoryID

A B C D E
1 Service Taxonomy |
2
3 J— Service Types
4 | Tutoring/homework assistancl( ID=1) i

’ ﬁ Service
5 Service Type Type ki Person Types ypes
6 |T-Tutoring [185 Student == [GEARUP
7 | —
g |Support Servicesl ID =43 ]I/
g Service Type Person Types Program Types
10 |SUP - Support Senices Student GEAR UP

EXT - Extracurricular Activity with definition or

11 example - GPA recognition GHK GEAR UP
12 |TST - Standardized Test Prep Student e CEAR UP
13
14 |Rigorous academic curricula (ID =2 P
15 Service Type SHITER NW% Types
16 |STEM - STEM Time 663 e o GEAR UP
17
18 |Comprehensive mentoring (ID =3 )

’ Service
19 Service Type Type Id Person Types Program Types
20 MEN - Mentoring 527 Student GEAR UP
82
33 Service Timings
84

N/A(ID=8)
B85
86 Service Timing rvice Timing Id
87 |MIA 27 |
| =]
B8
29 Service Deliveries
90 |, ,.
Virtuaj (ID=8)

91
92 Service Delivery i rvice Delivery Id
g3 |Virtual service delivery method

94

g

95 Real (Not Virtual) (ID=9)

95 Senvice Delivery Service Delivery Id
97 |(Real semnvice delivery method 26

98

33 | Telephonic ( ID =10

100 Service Delivery

Service Delivery Id

101 Telephonic service delivery method

27

ServiceDeliverylD
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Sample Service List Import File

SR RN TR IR

A B (@ D E F G H
ExternalServicelD ServiceName SchoolNumber [SchoolYear |StartDate |EndDate  |ServiceDeliveryCategoryld |ServiceDeliveryl
OneT.CS5.UCF.Apr2019.WEHS OneT.C55.UCF.Apr2019.WBHS 2 2019 4/5/2019 |4/5/2019 |8 25
OneT.FAC.FAFSAworkshopparents.Mar2019.WBHS |OneT.FAC.FAFSAworkshopparents.Mar2019.WBHS |2 2019 3/15/2019 |3/15/2019 |8 25
Rec.MEN.peer.Apr2015.WBHS Rec.MEN.peer.Apr2019.WBHS 2 2019 4/1/2020 |4/30/2020 |8 25
Rec.SWS.FridayParentworkshop.May2019.WBHS Rec.SWS.FridayParentworkshop.May2019.WBHS |2 2019 5/1/2019 |5/31/2019 |8 25
Rec.TMT.AlgebraZoomDropIn.Mar2020.WBHS Rec.TMT.AlgebraZoomDropln.Mar2020.WBHS 2 2019 3/1/2020 |3/30/2020 |8 25
Rec.TMT.AlgebraZoomDropln.Apr2020.WBHS Rec.TMT.AlgebraZoomDropln.Apr2020.WBHS 2 2019 4/1/2020 |4/30/2020 |8 25
Rec. TMT.AlgebraZoomDropin.May2020. WEHS Rec.TMT.AlgebraZoomDropln.May2020.WEBHS 2 2019 5/1/2020 |5/30/2020 |8 25

Import Course List file
1. Save the Service List import file following best practice naming conventions: include the school year,
type of import, other necessary details like month, quarter or semester, school/district name or

abbreviation (e.g., 19-20_ServicelList_January_WBHS).

2.

3. Click Add Import.

In SCRIBE, click Tools > Import.

b Reports *  Tools =

Instance

Courses

Import

T [

User =

GEAR UP Demo,

User Management

‘ Match Tracking

Standardized Tests

Help -

3

e to

" | Needin

k

rorts n

13

SCRIBE/S

GEAR UP Demo_Current

"4 Add Import |
Imports

Last 3 Months 8 Requiring Action [ My Imports [

School Year:

# SCRIBE Import

**k All Years **+* v | Keyword:

Showing 1 to 8 of 8 entries

All Imports E3

4. Select the Import Type:

Service List.
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Add Import
Import Source 2 ]

GEAR UP Demo - Cohort Model

Import Type 10}
Attendance and Disciplinary Actions
Course List

Service List

Service Participation

5. Make sure the School Year is correct. Click Browse to select the import file from your computer. Click
Upload Import File. Follow the import process.

GEAR UP Demo_Current # SCRIBE Import € Back to SCRIBE

M Import List

Add Import

a Provide your data as a CSV (comma-separated variable) file or MS Excel
(XLSX) file with one Worksheet. It's best to only include the data you
intend to be imported into SCRIBE.

@ View Specification

Import Source

GEAR UP Demo - Cohort Model

Import Type [11]
School Year
Service List
2019 - 2020 v
Import Config Data File
GEAR UP Demo - Cohort Model - Service List Choose import data file Browse

A
£ Upload Import File

Note: You must add participation to the services you have just created. See How to Add Participation
via Import and How to Add Participation Manually for instructions.

Additional Resources:

How to Import Data PDF and webinars
Troubleshooting Importing PDF and video
How to Add Services Manually

Log into the SCRIBE Help Desk using your SCRIBE log in.



https://xcalibur.freshdesk.com/support/solutions/articles/4000151989-how-to-add-participation-via-import
https://xcalibur.freshdesk.com/support/solutions/articles/4000151989-how-to-add-participation-via-import
https://xcalibur.freshdesk.com/support/solutions/articles/4000151988-how-to-add-participation-manually
https://xcalibur.freshdesk.com/support/solutions/articles/4000143824-how-to-import-data
https://xcalibur.freshdesk.com/support/solutions/folders/4000029877
https://xcalibur.freshdesk.com/support/solutions/articles/4000144060-troubleshooting-imports
https://xcalibur.freshdesk.com/support/solutions/articles/4000145117-video-troubleshoot-importing-in-scribe
https://xcalibur.freshdesk.com/support/solutions/articles/4000151987-how-to-create-a-service-manually
https://xcalibur.freshdesk.com/support/home

