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A student must be enrolled in (added to) SCRIBE whenever they enroll in a school served by the GEAR UP 
grant, transfer schools within the GEAR UP grant and at the beginning of each school year. Keeping enrollment 
current is important because it can affect the reliability of associated records like grades, participation, 
attendance, etc. Run a student enrollment export in SCRIBE for a list of currently enrolled students.   
 
Students can be enrolled in SCRIBE manually and through an import. A Student Enrollment Import is the most 

efficient way to enroll a large group of students, especially at the start of the school year or term. Enrolling 

students manually is best used for a handful of students, typically those who transfer into a school mid-term.  

 
This tutorial covers how to transform a spreadsheet that already contains student data so that you can import 
it into SCRIBE. There is another tutorial which overs how to create a student enrollment import file from an 
import template and requires that the students’ data be typed into the spreadsheet. 
 
Watch the Video: How to Enroll a Student via Import that corresponds to this tutorial.  
 

Transform an Existing File 
1. Review the file you have received to spot any errors that could prevent you from importing the data. 

Errors such as no field headings, zeroes instead of first names, etc. These errors will be obvious to 
detect and may require you to ask for a new file from your data contact.  
 

2. Determine the required and optional fields for a Student Enrollment Import. There are two ways: 
 

a. Look at the Import Template in your grant’s Google Drive folder. Every import template has a 
tab that has the field headings and a tab that describes each field, indicates whether the field is 
required, and lists the type of data needed for that field and where to find that data 

 

 

https://xcalibur.freshdesk.com/support/solutions/articles/4000159696-how-to-run-a-student-enrollment-export
https://xcalibur.freshdesk.com/support/solutions/articles/4000159234-how-to-enroll-a-student-manually
https://xcalibur.freshdesk.com/support/solutions/articles/4000159234-how-to-enroll-a-student-manually
https://xcalibur.freshdesk.com/support/solutions/articles/4000159235-how-to-enroll-a-student-via-import
https://xcalibur.freshdesk.com/support/solutions/articles/4000159235-how-to-enroll-a-student-via-import
https://xcalibur.freshdesk.com/support/solutions/articles/4000159578-video-how-to-enroll-a-student-via-import
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Note: Remember to download the Import Template from the Google folder and save it on your desktop 
before editing it. Click File > Download > Microsoft excel. 
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b. The second way to determine the required fields: In SCRIBE click Tools > Import.  
Click Add Import. Select the Import Type. Click the View Specification button.  

 
 

The Import Specification list will appear in a popup box. The fields with a red asterisk are required, the 
fields with a white circle are optional.  

 
 

Note: SCRIBE will consider any fields included in the import file that are not listed on the Import 
Specification list as “unknown” fields during the import process. See Troubleshooting Imports on the 
SCRIBE Help Desk for more information on unknown fields. 

 

https://xcalibur.freshdesk.com/support/solutions/articles/4000144060-troubleshooting-imports
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3. Edit the field headings in the data file you have received to match those listed in the Import template 
or the Field Specification list in SCRIBE.  
 
Note: Field headings must be spelled correctly but capitalization does not matter (e.g., SchoolNumber  

= schoolnumber = SCHOOLNUMBER = sChOOlnUmBer).  

There are no spaces in the field headings (e.g., SchoolNumber is not the same as School Number).  

Fields (columns) can be in the import file in any order. 

 

 
In the example above, SSID (column A) should read StudentID. There should be no spaces 

between First Name, Last Name and Middle Name (columns B, C, D).  

 

4. Make sure your file includes all the required fields (indicated in the import template and on the 

specification list in SCRIBE with a red asterisks). SCRIBE will not import the file if any of the required 

fields are missing.  

 

You may need to add a field if it is missing from the file you received. Commonly, users need to add the 

SchoolYear and SchoolNumber fields.  

 

 
In the example above, two columns were added and labeled as SchoolYear and 

SchoolNumber. Enter the SchoolYear and SchoolNumber in the correct columns for every 

line of data.  
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5. Ensure that the data contained in each column is written in a way that is readable by SCRIBE. Ensure 
that the correct codes are used for fields that require codes (e.g., ethnicity).  
 

a. Record any missing data, anomalies or unknown data (e.g., abbreviations or codes that you do 
not understand) and ask for clarification from your data contact who gave you the file.  

 

 
In the example above, there is no data for IsHomeless (column K), missing data for some 
students for FARM and IsInFosterCare (columns L and O) and “no” for all students for ESL 
(column M). These are anomalies worth asking your data contact to clarify and hopefully fill 
in missing data.  
 

 See Notes on the Student Enrollment Import below (p. 13) for more details on missing data.  
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Fields 

Fields are the different data categories you can include in the Student Enrollment import file (e.g., StudentID, 

SchoolNumber, ethnicity, etc.) listed as separate columns in the spreadsheet. Some fields are required, 

meaning SCRIBE will not import your file without them. Some are optional, meaning it is up to you whether to 

include them in the import file.  

 

Fields in a Student Enrollment Import (* indicates a required field) 

There are many fields to possibly include in the Student Enrollment import. The most common fields are 

detailed below. See the Import Specification list (step #1b above) for a complete list of all fields.  

 

a. StudentID*: unique identifier for each student used in SCRIBE. 
 
In SCRIBE, click Schools > View All Schools. 

 
 

Click View next to the school the student(s) attends.  
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Under the Students Tab, the students enrolled at the school will be displayed. Copy the student’s 
Student ID and paste it in the StudentID column in the Student Enrollment spreadsheet.  

 
 

b. FirstName*: student first name.  
 

c. MiddleName: student middle name.  
 

d. LastName*: student last name.  
 

e. Suffix: student suffix (e.g., Jr., III, etc.).  
 

f. SchoolNumber*: unique identifier for each school in SCRIBE. 
 
In SCRIBE click Schools > View All Schools. 
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The list of School Numbers are displayed in the School list. Copy the School Number of the school 
the students attend and paste it in the Student Enrollment Import spreadsheet in the 
SchoolNumber field. 

 
 

g. SchoolYear*: first year in the two year school year (e.g., “2019” for the 2019-2020 school year, 
“2020” for the 2020-2021 school year) 
 
Note: Import files are limited to one school year per file.  

 
h. GradeLevel*: grade the student is in for the specified school year.  

 
i. Gender: gender of student.  

Codes:     F for female 
     M for male 

 
j. BirthDate: student’s date of birth, written as MM/DD/YYYY. 

 
k. Ethnicity: student’s ethnicity.  

Codes:     codes vary by grant – see your grant’s SCRIBE manual. 
 

l. FARM: student’s free and reduced meals status (Yes or No).  
 

m. ESL: student’s English as a Second Language status (Yes or No). 
  

n. IEP: student’s Individualized Education Plan status (Yes or No). 
 

o. IsHomeless: indicates whether student is homeless (Yes or No). 
 

p. IsInFosterCare: indicates whether student is in foster care (Yes or No). 
 

q. Address1: first line of student’s home address (number and street). 
 

r. Address2: second line of student’s home address, if applicable (e.g., apartment number).  
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s. City: city where student lives. 
 

t. State: state where student lives. Must be the same state as the state the grant is in.  
 

u. Zip: 5-digit zip code where student lives.  
 

v. Email: student’s email address, either personal or school email address.  
 

w. HomePhone: student’s home phone. 
 

x. EntryCode: reason for student’s entry to the school. 
Codes:     codes vary by grant  – see your grant’s SCRIBE manual. 

 
y. EntryDate: date student enrolled in school, written as MM/DD/YYYY. 

 
z. EntryNote: comments about student’s entry details (e.g., school student transferred from). 

 
aa. ExitCode: reason for student’s exit from the school. 

Codes:     codes vary by grant – see your grant’s SCRIBE manual. 
 

bb. ExitDate: date student exited school, written as MM/DD/YYYY. 
 

ab. ExitNote: comments about student’s exit details (e.g., school student transferred to). 
   

See Deleting vs. Exiting Students for more information on when to exit a student.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

https://xcalibur.freshdesk.com/support/solutions/articles/4000159239-deleting-vs-exiting-students
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Sample Student Enrollment Import File 
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Import Student Enrollment File 
1. Save the Student Enrollment Import file following best practice naming conventions: include the school 

year, type of import, other necessary details like month, quarter or semester, school/district name or 
abbreviation (e.g., 19-20_enrollment_S1_WBHS). 
 

2. In SCRIBE, click Tools > Import.  

 
 

3. Click Add Import.  

 
 

4. Select the Import Type: Student Enrollment. 
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5. Make sure the School Year is correct. Click Browse to select the import file from your computer. Click 
Upload Import File.  

 
 

6. Follow the import process. See the Help Desk folder on Importing for more info. 

 
TIP: During the Data Summary phase of the import process, review the number of New / Existing Students 
for accuracy. Make sure the number of new students seems realistic to when you are importing the data. 
For instance, if you are importing a mid-year student enrollment file, you would expect a few new students 
who have transferred into the school. However, you would not expect to have dozens or hundreds of new 
students. That is an indication that SCRIBE is reading those student IDs as new students, meaning they are 
not matching any student ID assigned to a student already enrolled in SCRIBE. Check the student 
enrollment file to make sure the correct student IDs are in the file and there are no typos, added 0s, etc. 
Make any changes necessary to the student enrollment file and reimport it.  
 
If you have any questions about this, reach out to your data team or Xcalibur contact BEFORE you 
complete the import. 

https://xcalibur.freshdesk.com/support/solutions/folders/4000029874
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Notes on the Student Enrollment Import 

a. A student enrollment import file can contain students who are already enrolled in SCRIBE for the same 
school year. This typically happens for mid-year and end of the year enrollments where many of the 
students have already been enrolled in SCRIBE at the beginning of the year.  
 
Any data in the student enrollment file for enrolled students will overwrite their existing data in 
SCRIBE. For instance, if an enrolled student has a “no” for FARM status in SCRIBE and the student 
enrollment import has a “yes” for FARM status, once the file is imported in SCRIBE, the student’s FARM 
status will be “yes” in SCRIBE.  
 
If the student enrollment file has a blank in any field for an enrolled student, the data that exists in 
SCRIBE will remain the same. For instance, if an enrolled student has a “no” for FARM status in SCRIBE 
and the student enrollment import has a blank for that student for FARM status, once the file is 
imported in SCRIBE, the student’s FARM status will remain “no” in SCRIBE. 

 
b. To update data for students already enrolled in SCRIBE, you can create a student update import 

instead of a student enrollment import. The advantage of using a student update import is that there 
are less required fields but can contain any field in the student enrollment file. It is important to note 
that any blank fields in a student update import will overwrite existing data in SCRIBE to read 
unknown.  
 
See the How to Update Student Data using a Student Update Import article on the Help Desk for more 

info.  

https://xcalibur.freshdesk.com/support/solutions/articles/4000159236-how-to-update-student-data-using-a-student-update-import
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Additional Resources 
How to Import Data and webinars on importing data 
Troubleshooting Imports 
Video: How to Enroll a Student via Import 

 

How to Enroll a Student Manually 

Video: How to Enroll a Student Manually 
How to Run a Student Enrollment Export 

 
Log into the SCRIBE Help Desk using your SCRIBE log in. 
 

https://xcalibur.freshdesk.com/support/solutions/articles/4000143824-how-to-import-data
https://xcalibur.freshdesk.com/support/solutions/folders/4000029877
https://xcalibur.freshdesk.com/support/solutions/articles/4000144060-troubleshooting-imports
https://xcalibur.freshdesk.com/support/solutions/articles/4000159578-video-how-to-enroll-a-student-via-import
https://xcalibur.freshdesk.com/support/solutions/articles/4000159234-how-to-enroll-a-student-manually
https://xcalibur.freshdesk.com/support/solutions/articles/4000159234-how-to-enroll-a-student-manually
https://xcalibur.freshdesk.com/support/solutions/articles/4000159523-video-how-to-enroll-and-student-manually
https://xcalibur.freshdesk.com/support/solutions/articles/4000159696-how-to-run-a-student-enrollment-export
https://xcalibur.freshdesk.com/support/home

