How to Add Grades via Import

Users can add Grades for a student manually and through an import. This PDF covers adding grades via
import. See the How to Add Grades Manually article on the SCRIBE Help Desk. When adding grades manually,
you must add grades for each student one by one. When adding grades using an import file, you can include
multiple students and multiple courses for those students in the same file.

Before grades can be added for a student, courses must be entered into SCRIBE. See How to Add a Course
Manually and How to Add a Course via Import for more information on adding courses.

Create the File to Import
1. Determine the required and optional fields for a Grades import. There are two ways:

a. Look at the Import Template in your grant’s Google Drive folder. Every import template has a
tab that has the field headings and a tab that describes each field, whether the field is required,
the type of data needed for that field and where to find that data

A B C D E F G H | ]
1 |StudentID |SchoolMumber ‘Schc—olYear |Cc—urseNumber |Grade |Term |Gmr;a‘eLeveI | FirstName | LastName ‘ CourseNumber
A
3
i
3
6
Grades FieldDescriptions ®
A B C D
Field Name Required? Comments Values to lookup
1
SSID Required Student ID
2
SchoolNumber Required School Number In SCRIBE, Schools > View All Schools for a list of School Numbers
3
SchoaolYear Required School Year 2017: 2017-2018
a 2018: 2018-2019
CourseNumber Required All courses must exist within the appropriate school for
5 the appropriate school year.
Grade Required Course Grade 0-100 for Decimal Courses
6 For Lookup Courses, refer to the course result group.
Term Required Term Q1, Q2, Q3, Q4, 51, S2, Final, or Summer
T
Gradelevel Not Imported used for dota
8 colfection
FirstName Not Imparted used for data
3 colfection
LastName Not Imported used for data
10 collection
Coursenumber Not Imported used for data
1 colfection
12
13 Column MUST be in the file import
14 Not Used in import at all - to aid user in reviewing file
15
Grades | FieldDescriptions ® [

Note: Remember to download the Import Template from the Google folder and save it on your desktop
before editing it. Click File > Download > Microsoft excel.
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b. The second way to determine the required fields: In SCRIBE click Tools > Import. Click Add
Import. Select the Import Type. Click the View Specification button.

SCRIBE/S  schige support

GEAR UP Demo_Current # SCRIBE Import € Back to SCRIBE
(wrre]
Add Import

Import Source a Provide your data as a CSV (comma-separated variable) file or MS Excel

(XLSX) file with one Worksheet. It's best to only include the data you intend
to be imported into SCRIBE.

© View Specification

GEAR UP Demo - Cohort Model

Import Type 11]
School Year
Student Course Grades
2019 - 2020 v
Import Config Data File
GEAR UP Demo - Cohort Model - Course and Grades Choose import data file Browse

 A———————
X, Upload Import File

The Import Specification list will appear in a popup box. The fields with a red asterisk are required.

Import Specification *
GEAR UP Demo - Cohort Model - Course and Grades

* = Required - field must be in your file
O = Optional - field should only be in your file if you are providing values

Field Status Description

StudentlD *  Studentidentifier

SchoolNumber t School identifier

SchoolYear * School Year (ex: 2010 for the 2010-2011 school year)
CourseNumber E ] Course identifier

Term * Term identifier (ex: Q1, Q-Final, S2, etc.)

Grade t 3 Grade value (ex: 92, A-, etc., depending on Course's Grade Type)

A—————
Close

Note: SCRIBE will consider any fields included in the import that are not listed on the Import
Specification list as “unknown” fields during the import process.




Fields
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Fields are the different data categories you can include in the Grades import file (e.g., StudentID,

SchoolNumber, etc.) listed as separate columns in the spreadsheet. Some fields are required, meaning SCRIBE

will not import your file without them. Some are optional, meaning it is up to you whether or not to include
them in the import file.

Note: Fields (columns) can be in the import file in any order. Field headings must be spelled correctly but

capitalization does not matter (e.g., SchoolINumber = schoolnumber = SCHOOLNUMBER = sChOOInUmBer).

There are no spaces in the field headings (e.g., SchoolNumber is not the same as School Number).

Fields in a Grades Import (* indicates a required field)

a.

StudentID*: unique identifier for each student used in SCRIBE.

In SCRIBE, click Schools > View All Schools.

soripES e
]

Home ~ Districts = Schools - Student Search Services -

View All Schools

Click View next to the school the student(s) attends.

© search

View
View
View
View

View

5 Items

SCRIBE Home > School List

The following are all the available schools.
Click the View link to see additional details for a school. Click the Search link to filter the list of schools.

Drag a column header here to group by that column

School Number « | School Name District Name
1 Bayside Middle School Test District
2 West Beverly High School Test District
3 William McKinley High School Test District
4 DeGrassi Junior High Test District
5 College Test District

Pages: 1 - 1 (5 items)

Grades
7-8
9-12
9-12
7-8

Post-Secondary - Fresh

Page size: All | =
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Under the Students Tab, the students enrolled at the school will be displayed. Copy the student’s
Student ID and paste it in the StudentID column in the Service Participation spreadsheet.

SCRIBE Home > School List > School Details

. School Number: 2  School Name: West Beverly High School

School Record School Year Details | Staff | Students Courses Services Student Groups Attachments

The following are the students enrolled at this school.
Click the add button to enroll a student at the school.
© search
Add
Drag a column header here to group by that column
Student ID o || iR First Name Middle Name Last Name Birthdate School Grade
View 108642 Steve Rogers 7/4/2000 West Beverly High 9
School
View 108643 Peggy Carter 4/9/2001 West Beverly High 10
School
View 108644 James Bucky Barnes 3/10/2002 West Beverly High 1
School
view 123456 carol Susan Jane Danvers 10/4/2000 gvj_f;ﬂ?e"e”" High 12
View 123457 Captain Marvel 10/5/2003 West Beverly High 9
School
\Mast B, ol High

b. SchoolNumber*: unique identifier for each school in SCRIBE.

In SCRIBE click Schools > View All Schools.

I —
|

Home ~ Districts ~ Schools = Student Search Services ¥

View All Schools

The list of School Numbers are displayed in the School list. Copy the School Number of the school
the students attend and paste it in the Grades Import spreadsheet in the SchoolNumber field.

SCRIBE Home > School List

The following are all the available schools.
Click the View link to see additional details for a school. Click the Search link to filter the list of schools.

© search

Drag a column header here to group by that column

| School Number 4 | School Name District Name Grades
View 1 Bayside Middle Schoaol Test District 7-8
View 2 West Beverly High School Test District 9-12
View 3 William McKinley High School Test District 9-12
View 4 DeGrassi Junior High Test District 7-8
View 5 College Test District Post-Secondary -

5 Items Pages: 1 - 1 (5 items) Page size: -
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SchoolYear*: first year in the two year school year (e.g., “2019” for the 2019-2020 school year,
“2020” for the 2020-2021 school year)
Note: Import files are limited to one school year per file.

Course Number*: unique identifier for each course for the school.

In SCRIBE click Schools > View All Schools.

sorine/ Em—"
.

Home ~ Districts = Schools = Student Search Services

View All Schools

Click View next to the school the students attend.

SCRIBE Home > School List

The following are all the available schools.
Click the View link to see additional details for a school. Click the Search link to filter the list of schools.

© search

Drag a column header here to group by that column

School Number « | School Name District Name Grades
View 1 Bayside Middle School Test District 7-8
View 2 West Beverly High School Test District 9-12
View 3 William McKinley High School Test District 9-12
View 4 DeGrassi Junior High Test District 7-8
View 5 College Test District Post-Secondary - Fresh
5 Items Pages: 1 - 1 (5 items) Page size: |All | =

Click the Courses tab to see all courses that have been added for that school. Copy the Course
Number next to the course you want to add grades for and paste it in the CourseNumber field in
the grades spreadsheet.

SCRIBE Home > School List > School Details

School Number: 2 School Name: West Beverly High School

School Record School Year Details Staff Students Courses Services Student Groups Attachments

The following are the courses offered at this school. Click the add button to add a course to the school.

© search
Add
Drag a column header here to group b L ——

se Result
P

Course Name Course Number lourse Type Course Level Credits Scoring Method (C;SIZ Standard Course
SCRIBE Default
- Generic
Grade A+ to
D-,FRINC
SCRIBE Default
- Generic
Grade A+ to
D-,FRI,NC
SCRIBE Default
- Generic
Grade A+ to
D-,FRINC

View Alg I Hon Alg12019Henwbhs Honors/Advanced 0.50 Lookup Algebra I

View Algebra [ Alg12019wbhs 0.50 Lookup Algebra [

View  Algebra IT Alg22019wbhs 0.50  Lookup Algebra IT

SCRIBE Default
- Generic
Grade Ae to

View Algebra IT Honors Alg22018Honwbhs Honors/Advanced 0.50 Lookup Algebra I1
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Click the grey circle next to Search to reveal the Search Box. This will allow you to search for a
course by Course Name or Course Number and/or to change the School Year to view courses
from previous years. The Advanced Search box will allow you to narrow the courses displayed on
the course list below. Click Search.

© search

Course Name:
Course Number:
School Year: 2019 - 2020 v

Mot Mapped To Selected School Year
© Advanced Search

Course Type: A
Course Level: v
Scoring Method: v
Course Result Group: A
Standard Course: v
Reset Search

Note: Another way to find Course Numbers is to run a Course List Export from SCRIBE. This export will
produce a spreadsheet with all courses and course numbers for the school(s) and school year selected.

In SCRIBE, click Reports > Courses > Course List Export.
See How to Run a Course List Export on the SCRIBE Help Desk for more information.

e. Term*:indicates which term (e.g., quarter 1, semester 2, final, etc.) the grade is for.

Codes: Q1 for Quarter 1 T1 for Trimester 1 S1 for Semester 1
Q2 for Quarter 2 T2 for Trimester 2 S2 for Semester 2
Q3 for Quarter 3 T3 for Trimester 3
Q4 for Quarter 4

Final for final grade for the entire school year


https://xcalibur.freshdesk.com/support/solutions/articles/4000158436-how-to-run-a-course-list-export
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f. Grade*: grade value. Decimal (0-100) or lookup (letter).

Note: The scoring method entered in the Grades field (decimal or lookup) must match the scoring
method assigned to the course when the course was created and entered into SCRIBE. If the scoring
method used in the grades import does not match that for the course in SCRIBE, you will get an error
during the import process and will be unable to import grades for that course.

To check the scoring method for a course, look at the Scoring Method column on the course list in
SCRIBE or on the Course List Export (follow steps for Course Number in step d above).

SCRIBE Home > School List > School Details
School Number: 2 School Name: West Beverly High School
School Record School Year Details Staff Students Courses Services Student Groups Attachments
The following are the courses offered at this school. Click the add button to add a course to the school.
© search
Add
Drag a column header here to group by that column
Course Name ~ | Course Number Course Type Course Level Credits Scoring Method r;‘n‘;s: Result Standard Course

[CRIBE Default

View Alg 1 Hon Alg12019Honwbhs Honors/Advanced 0.5@ Lookup gedn::i to Algebra L
|- FRINC
[CRIBE Default

; Generic

View ‘

view  Algebral Alg12019wbhs 0.5q Lookup ade A+ to Algebra I
| FRLNC
[CRIBE Default

: Generic

View wl

View Algebra IT Alg22019wbhs 0.5 Lookup ade A+ to Algebra I1
- FRILNC
[CRIBE Default

View Algebra IT Honors Alg2201%Honwbhs Honors/Advanced 0.5 Lookup rGjrf:'i . Algebra I1

g. FirstName: student first name. This field is optional and for ease of reviewing the grades file only.
During the import process, SCRIBE will flag this field as unknown which means it will not import
data in this field. It will not interfere with the import process.

h. MiddleName: student middle name. This field is optional and for ease of reviewing the grades file
only. During the import process, SCRIBE will flag this field as unknown which means it will not
import data in this field. It will not interfere with the import process.

i. LastName: student last name. This field is optional and for ease of reviewing the grades file only.
During the import process, SCRIBE will flag this field as unknown which means it will not import
data in this field. It will not interfere with the import process.
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Sample Grades Import File

A B C D E F G H |
1 |Studentld |schoolnumber |schoolyear [term |CourseNumber |Grade |[FirstName MiddleName LastName
2 |101571727 |2 2013 Final |10014152IBwbhs (B SAMNCHEZ RASCON Q KARINA
3 (101783884 (2 2019 Final |100141521Bwbhs  [A- Mendoza G Julian
4 (101785749 (2 2019 Final |100141521Bwbhs (C Suina Q Karen
5 |101785848 |2 2015 Final |100141521Bwbhs |C+ Garviso Y Ana
6 (101736002 |2 2019 Final [100141521Bwbhs D+ Sisneros Q Marvin
7 |101786044 |2 2019 Final |100141521Bwbhs [D- Rosetta ] Benny
8 101786085 |2 2019 Final |[10014152IBwbhs  (F Markcum X Brayan
g (101786168 (2 2019 Final |10014152IBwbhs |A Armenta ¥ Reanna
10 101786267 |2 2015 Final |100141521Bwbhs |C Farmer C Christopher
11 |101786283 (2 2019 Final |[10014152I1Bwbhs  [D- Maldonado T Shauncey
12 |101786630 |2 2019 Final |100141521Bwbhs (B Garcia V Keion
12 101786770 |2 2013 Final |10014152I1Bwbhs  [A+ Brazil U Skylar
14 101802718 (2 2018 Final |10014152I1Bwbhs |C Duran 8] Edwin
15 (101808582 (2 2019 Fimal [100141521Bwbhs [C Candelaria K Alcario
16 (101811255 |2 2019 Final |10014152I1Bwbhs |C+ Fernandez T llana

Import Grades File
1. Save the Grades Import file following best practice naming conventions: include the school year, type

of import, other necessary details like month, quarter or semester, school/district name or

abbreviation (e.g., 19-20_Grades_S1_WBHS).

2. In SCRIBE, click Tools > Import.

GEAR UP Demo

v  Reports ¥ | Tools ¥ User ¥ Help ~ ‘
Instance ’
User Management e to
‘ Match Tracking * | Needin
| Courses 4
k orts n

Standardized Tests  *
Import

7

3. Click Add Import.

SCRIBE/

GEAR UP Demo_Current

# SCRIBE Import

Imports

Last 3Months @  Requiring Action ) ALl sl Al Imports )
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4. Select the Import Type: Student Course Grades.

Add Import
Import Source B
Import Type (11)

Attendance and Disciplinary Actions
College Enrollment - Outreach Format
Course List

Service List

Service Participation

Standardized Tests and Assessments

Student Course Grades

5. Make sure the School Year is correct. Click Browse to select the import file from your computer. Click
Upload Import File. Follow the import process.

GEAR UP Demo_Current # SCRIBE Import 4 Back to SCRIBE
=]
Add Import

Import Source a Provide your data as a CSV (comma-separated variable) file or MS Excel

(XLSX) file with one Warksheet. It's best to only include the data you
intend to be imported into SCRIBE.

© View Specification

GEAR UP Demo - Cohort Model

Import Type @
School Year
Service List
2019 - 2020 v
Import Config Data File
GEAR UP Demo - Cohort Model - Service List Choose import data file HTEE

. Upload Import File
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Additional Resources

How to Import Data PDFs and webinars
Troubleshooting Imports

How to Add a Course Manually

How to Add a Course via Import

How to Add Grades Manually

How to Run a Course List Export

How to Run a Student Transcript — Course Grades Export

Log into the SCRIBE Help Desk using your SCRIBE log in.
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