How to Add Participation via Import

Users can add Service Participation manually and through an import. This PDF covers adding service
participation via import. See How to Add Participation Manually on the SCRIBE Help Desk.

Before participation can be added for a service, the service must exist in SCRIBE. See How to Create a Service
Manually and How to Create a Service via Import for more information on creating services.

Create the File to Import
1. Determine the required and optional fields for a Service Participation import. There are two ways:
a. Look at the Import Template in your grant’s Google Drive folder. Every import template has a
tab that has the field headings and a tab that describes each field, whether the field is required,
the type of data needed for that field and where to find that data.

ServiceParticipation_ImportTemplate ~ B
File Edit View Insert Format Data Tools Add-ons Help All changes saved in Drive
~ o~ T O100% v $ % 0 .00 123y Default(Ai. v 10 ~ B I S A & H Ev le|s- V-
A B I C D E F G H | J
1 ExternalServicelD | PersonlD PersonTypelD | SchoolNumber | DateOfParticipation | TimeOfParticipation |HoursOfParticipation | MinutesOfParticipation | FirstName | LastName
2
4
]
+ = ServiceParticipation ~ FieldsDescribed ~
A B ® D
1 Field Name Required Values Comments
2 ExternallD Required Service identifier
This is the SSID for students.
For parents, use the SSID, but change the
3 PersonTypelD field to 2.
This tells SCRIBE that parent participation is being
PersonlID Required numeric imported.
4 1 =Student, 2 = Parent, 3 = This tells the import that the person is a student,
PersonType Required Teacher parent, or teacher
5 In SCRIBE, Schools > View All
SchoolNumber Required Schools to view School Numbers. |The Unique Identifier for the school
6 DateOfParticipation Required mm/dd/yyyy Date when the person participated in service
7 TimeOfParticipation eg. 4:00 PM, 11:00 AM Time of the event if tracked at a time level
8 HoursOfParticipation Required Use either minutes or hours
9 MinutesOfParticipation |Required Use either minutes or hours
10 FirstName NOT IMPORTED - Used for informational purposes only to easy verfiying the file for the user.
11 LastName NOT IMPORTED - Used for informational purposes only to easy verfiying the file for the user.
+ = ServiceParticipation ~ FieldsDescribed ~

Note: Remember to download the Import Template from the Google folder and save it on your desktop
before editing it. Click File > Download > Microsoft excel.
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b. The second way to determine the required fields: In SCRIBE click Tools > Import. Click Add
Import. Select the Import Type. Click the View Specification button.

SCRIBE/  scRiBE suppore

GEAR UP Demo_Current # SCRIBE Import € Back to SCRIBE
=
Add Import

\mport Source a Provide your data as a CSV (comma-separated variable) file or MS Excel (XLSX) file with

one Worksheet. It's best to only include the data you intend to be imported into SCRIBE.

GEAR UP Demo - Cohort Model S Ve et et

\mport Type B School Year
Data File
Import Config
Choose import data file Browse

GEAR UP Demo - Cohort Model - Service Participation

——
&, Upload Import File

The Import Specification list will appear in a popup box. The fields with a red asterisk are required, the
other fields are optional.

Import Specification x

GEAR UP Demo - Cohort Model - Service Participation

This import is used to import Service Participation. The participants (Students, Teachers, Parents) and
Services must already exist in the system. If necessary, the "Service List" files should be uploaded and
successfully imported before this file.

% = Required - field must be in your file
O = Optional - field should only be in your file if you are providing values
O = Set - at least one of the fields in a set must be in your file

Field Status Description

ExternalServicelD %  Service identifier

Personld %  Person identifier

PersonTypelD * Person Type identifier

SchoolNumber %  School identifier

DateOfParticipation %* Date person participated in service (ex: mm/dd/yyyy)
TimeOfParticipation O  Time of day person participated in service (ex: hh:mmAM)
HoursOfParticipation * O Hours of participation

MinutesOfParticipation # @] Minutes of participation

A - At least one of the following fields must be in the file: HoursOfParticipation, MinutesOfParticipation

G
Close

Note: SCRIBE will consider any fields included in the import that are not listed on the Import
Specification list as “unknown” fields during the import process. See the Importing Data folder and
Troubleshooting Imports tutorial for more info.
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Fields
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Fields are the different data categories you can include in the Participation import file (e.g., SchoolYear,

SchoolNumber, etc.) listed as separate columns in the spreadsheet. Some fields are required, meaning SCRIBE

will not import your file without them. Some are optional, meaning it is up to you whether or not to include
them in the import file.

TIP: Fields (columns) can be in the import file in any order. Field headings must be spelled correctly but
capitalization does not matter (e.g., SchoolYear = schoolyear = SCHOOLYEAR = sChOOIlyEaR). There are no

spaces in the field headings (e.g., SchoolYear is not the same as School Year).

Fields in a Service List Import (* indicates a required field)
a. ExternalServicelD*: unique identifier for each service using recommended naming conventions.

In SCRIBE, click Services > View All Services.

GEAR UP Demo_Current

Services - Reports

Student Search

Add Service

View All Services

- Tools

View All Service Templates

- User = Hel
:RIBE
Imp

Click View next to the service for which you want to add participation.

SCRIBE Home > Service List

View

View

View

View

View

0 Items

© search

Start Date

12/1/2019

11/1/2019

10/1/2019

9/1/2019

8/1/2019

Drag a column header here to group by that column

* | Service Name

Rec.MEN.peer.Dec2019.WBHS

OneT.CSS.UTSA.Nov2019. WBHS

Rec. TMT.AlgebraafterSchool Oct2019.WBHS

Rec.SWS. Fridayworkshop.Sep2019.WBHS

OneT.FAC.FAFSAworkshop.Aug2019. WBHS

Participants
0

0

10

0

0

Total: 10

Service Type

MEN - Mentoring

CSS - College Student
Shadowing

TMT - Math Tutoring

SWS - Student Workshops

FAC - Financial Aid
Counseling / Advising

Pages: 1 - 1 (5 items) 1

Service Type Additional
Information

testing123

Is

STEM?

No

No

No

No

No

The following are all the services. Click the view link to see additional details for a service. Click the search link to filter the list of services, Click the add button to add a new service.

Person Type(s)

Student

Student

Student

Student

Student

School(s)

West Beverly High
School

West Beverly High
School

West Beverly High
School

West Beverly High
School

West Beverly High
School

Add

Hours

0 Hrs 0 Mins

0 Hrs 0 Mins

50 Hrs 15 Mins

0 Hrs 0 Mins

0 Hrs 0 Mins

Total: 50 Hrs 15 Mins

Page size: |All

Copy the External ID and paste it in the ExternalServicelD field in the Service Participation import
spreadsheet.
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SCRIBE Home > Service List > Service Details
Service Name: Rec.MEN.peer.Dec2019.WBHS Start Date: 12/1/2019 End Date:
l Service Details Participation [ Service Summary | Attachments
This tab shows the detail information for the service.
Click the Edit button to edit the service details.
School(s): West Beverly High School
School Year: 2019 - 2020
Service Name: Rec.MEN.peer.Dec2019.WBHS
i : 30
External Id: Rec.MEN.peer.Dec2019.WBHS I
ar ate: 1/2/1/201%9
End Date: 12/31/2019
Service Provider(s):
Service Summary: Default Activity Summary
Is STEM? No
b. StudentID*: unique identifier for each student used in SCRIBE.
In SCRIBE, click Schools > View All Schools.
Home ~ Districts ~ Schools ~ Student Search Services T
View All Schools
Click View next to the school the students attend.
SCRIBE Home > School List
The following are all the available schools.
Click the View link to see additional details for a school. Click the Search link to filter the list of schools.
© search
Drag a column header here to group by that column
- School Number 4 | School Name District Name - Grades
View 1 Bayside Middle School Test District 7-8
View 2 West Beverly High School Test District 9-12
View 3 William McKinley High School Test District 9-12
View 4 DeGrassi Junior High Test District 7-8
View 5 College Test District Post-Secondary - Fresh|
5 Items Pages: 1 - 1 (5 items) Page size: |All |~

Under the Students Tab, the students enrolled at the school will be displayed. Copy the student’s
Student ID and paste it in the StudentID column in the Service Participation spreadsheet.
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SCRIBE Home > School List > School Details

School Number: 2  School Name: West Beverly High School

School Record School Year Details Staff Students Courses Services Student Groups Attachments

The following are the students enrolled at this schaool.
Click the add button to enroll a student at the school.
© search
Add
Drag a column header here to group by that column
Student ID ISdChOOFStUdE”t First Name Middle Name Last Name Birthdate School Grade
View 108642 Steve Rogers 7/4/2000 West Beverly High 9
Schaol
View 108643 Peggy Carter 4/9/2001 West Beverly High 10
School
View 108644 James Bucky Barnes 3/10/2002 West Beverly High 1
Schaol
View 123456 Carol Susan Jane Danvers 10/4/2000 gceﬁgo?everly High 12
View 123457 Captain Marvel 10/5/2003 West Beverly High 9
Schaol
\Wact Ravarh: Hiah

c. PersonTypelD*: indicates what group of people participated in the service.
Codes: 1 for students
2 for parents/guardians
3 for staff

Note: Best practice recommends assigning one PersonType per service. If a service caters to more
than one person type (e.g., financial aid night for parents and students), create one service for

students and another service for parents/guardians.

d. SchoolNumber*: unique identifier for each school used in SCRIBE.

In SCRIBE click Schools > View All Schools.

soriBES e
]

Home ~ Districts = Schools = Student Search Services -

View All Schools

The list of School Numbers are displayed in the School list. Copy the School Number of the school the
students attend and paste it in the Student Participation Import spreadsheet under the SchoolNumber
field.
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SCRIBE Home > School List

The following are all the available schoaols.
Click the View link to see additional details for a school. Click the Search link to filter the list of schools.

© search

Drag a column header here to group by that column

School Number 4 | School Name District Name Grades
View 1 Bayside Middle School Test District 7-8
View 2 West Beverly High School Test District 9-12
View 3 William McKinley High School Test District 9-12
View 4 DeGrassi Junior High Test District 7-8
View 5 College Test District Post-Secondary -
5 Items Pages: 1 - 1 (5 items) 1 Page size: |All | =

DateofParticipation*: the date the students/parents/staff participated.

Note: You can enter multiple different dates in the same Participation import, if applicable. For
recurring services, it may be useful to include multiple dates of participation for the same service in the
same import file. Be sure to only include students who actually participated on each date.

TimeofParticipation: the time the participation occurred. Military and non-military time are both
acceptable (e.g., 1:00 and 13:00)

HoursofParticipation or MinutesofParticipation: time each student/parent/staff spent at the service.

One of the fields* must be in the file. If one field is included, the other field should NOT be included
(e.g., if the HoursofParticipation field is included, do not include the MinutesofParticipation field).

Note: 1.5 in the HoursofParticipation field means the same as 90 in the MinutesofParticipation field.

FirstName: student first name. This field is optional and for ease of reviewing the participation file only.
During the import process, SCRIBE will flag this field as unknown which means it will not import data in
this field. It will not interfere with the import process.

LastName: student last name. This field is optional and for ease of reviewing the participation file only.
During the import process, SCRIBE will flag this field as unknown which means it will not import data in
this field. It will not interfere with the import process.
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Sample Participation List Import File

A B C D E F G H 1 J
ExternallD StudentID |Person [School |DateOf TimeOf HoursOf MinutesOf  |FirstName |LastName
1 TypelD |Number |Participation Participation |Participation |Participation
2 |OneT.FAC.FAFSAworkshop Aug2019.WBHS (432124 1 2 &f2/2019 2.5 Bruce Banner
3 OneT.FAC.FAFSAworkshop.Augzol‘B.WBHS 108644 1 2 &f2f2019 2.5 James Barnes
4 |OneT.FAC.FAFSAworkshop.Aug2019.WBHS |789101 1 2 8/2/2019 2.5 Luke Cage
5 |OneT.FAC.FAFSAworkshop.Aug2019.WBHS |108643 1 2 8/2/2019 2.5 Peggy Carter
6 |OneT.FAC.FAFSAworkshop.Aug2019.WBHS (789789 1 2 8/2/2019 2.5 Mike Colter
7 |OneT.FAC.FAFSAworkshop.Aug2019.WBHS (123456 1 2 &f2/2019 2.5 Carol Danvers

Import Participation file
1. Save the Participation import file following best practice naming conventions: include the school year,
type of import, other necessary details like service details, school/district name or abbreviation (e.g.,
19-20_participation_FAFSA_Aug2019_WBHS).

2. In SCRIBE, click Tools > Import.

GEAR UP Demo

v Reports ~ Tools - User = Help ~
Instance 4
User Management e to
| Match Tracking * |Needin

Courses »

] Standardized Tests 4 Er0
Import

(|

3. Click Add Import.

SCRIBE/S  ScRIBE support

GEAR UP Demo_Current # SCRIBE Import

"+ Add Import
Imports

Last 3 Months @)  Requiring Action ) ALl = @ Al Imports 3

School Year:| *** All Years *** v Keyword:

Showing 1 to 8 of 8 entries
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4. Select the Import Type: Service Participation.

Add Import

Import Source

Import Type

Attendance and Disciplinary Actions
College Enrollment - Outreach Format
Course List

Service List

Service Participation

GEAR UP Demo - Cohort Model

5. Make sure the School Year is correct. Click Browse to select the import file from your computer. Click

Upload Import File. Follow the import process.

See the tutorials in the Importing Data folder, Troubleshooting Imports and the Import webinars from

June, 2020 on the SCRIBE Help Desk for more info on importing files in SCRIBE.

GEAR UP Demo_Current

= Import List

Add Import

# SCRIBE Import

Import Source B

GEAR UP Demo - Cohort Model

Import Type

Service Participation

Import Config

GEAR UP Demo - Cohort Model - Service Participation

€ Back to SCRIBE

Provide your data as a CSV (comma-separated variable) file or MS Excel (XLSX)
file with one Worksheet. It's best to only include the data you intend to be
imported into SCRIBE.

© View Specification

School Year

2019 - 2020 M

Data File

Browse

A——
X Upload Import File

Choose import data file

(o]
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Additional Resources:

How to Create a Service Manually

How to Create a Service via Import

How to Add Participation Manually

How to Add Participation Manually using a Student Group
How to Run a Student Participation Export

Log into the SCRIBE Help Desk using your SCRIBE log in.
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